mdsk.net
当前位置:首页 >> 引入的插件js文件与jquEry.min.js高版本出错,低版... >>

引入的插件js文件与jquEry.min.js高版本出错,低版...

应该是js文件中有的函数在高版本中被放弃了,比如live()从1.9开始就被on()代替了,不嫌麻烦可以找出来替换掉,不然就jquery降到兼容的版本

jquery.min.js有错误一般情况是不会是jquery.min.js本身js错误、除非版本过低.引起的错误都是你的另外写的jq语法有错误.仔细检查你自己写的JQ、实在找不到问题、建议用排查法.注释某块JQ.或者删除.然后刷新试试还有没有错误、一块一块去排查、 目前没有遇到过你发的错误、具体还是你个人自己去排查啦

1. 导入会报错,js在myeclipse里面的validate本来就容易出错2. myeclipse打开只有一点儿代码;因为是横向的滚动条,其实很多的代码.3. 外边打开很多代码,很乱,是因为没有格式化好.

jQuery-1.4.4.min.js简单的说就是js封装好的框架,引入其他js文件之前也不一定就得引入jQuery-1.4.4.min.js文件,如果你引用的其他js文件没用到jQuery-1.4.4.min.js这里面的功能,是不需要引用的,如果某些js是基于jQuery-1.4.4.min.js框架开发的,那必须引用!

只有看版本信息.如果jQuery.js 是2.0+ 的版本,见不会支持IE6/7/8但是一个HTML文件中引入2个JQuery文件,过于浪费资源.

1、选中报错的jquery文件“jquery.min.js”.2、右键选择 MyEclipse-->Exclude From Validation .3、再右键选择 MyEclipse-->Run Validation 即可.

jquery的库2113,只需要引入一个就行了,多个版本的jquery库会冲突5261的所以,你留下一个最新4102版本的jqeruy文件就行了~上面两个你随便留下一个,删除另1653外一个就专OK~页面该有的效果,什么轮播,什么客服都是可以用的属,放心吧~

最好只用一个,准确的说,是同一个页面里面只用一个版本,否则可能会无所适从,之用文件命名,就直接用官网的命名方式即可.

网页表单限制--是表单验证吗?如果少的话就写在jsp页面吧,建议删除p.js,保留jquery-1.4.2.min.js.

是的,jquery.min.js是jquery.js把代码进行特殊的压缩处理,在不影响功能的情况下尽可能减少体积的产物,所以.min.js文件容量比较小,一般在网页中调用这个文件,但是处理过的代码人类阅读起来相当吃力,如果要看源码还是看jquery.js

相关文档
网站首页 | 网站地图
All rights reserved Powered by www.mdsk.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com