mdsk.net
当前位置:首页 >> opEnCv支持python3吗 >>

opEnCv支持python3吗

就opencv本身而言,opencv是用c++写的,但是提供python的接口,c++执行效率更高,python开发效率更高(前提是python和c++都同样熟悉).

官方不支持,建议等支持吧. dll有自己版本对应的,必须使用专门为python3.4编译的dll(cv2.pyd),你拿python2.7的肯定用不了. 如果非要使用 方法一:自己编译opencv的源码 方法二:安装python2.7

支持,最新版本是opencv-python 3.3.0.10 记得可以通过pip安装.

先进入如下连接下载python和系统版本对应的opencv包:http://www.lfd.uci.edu/~gohlke/pythonlibs/#opencv 比如我的版本是64位的python 3.41,那么我就下载:opencv_python-3.1.0-cp34-cp34m-win_amd64.whl2 下载后修改文件名(这就是安装

pip install python-opencvpip3 install python-opencv一个对应 python2(或 python3)一个只能对应 python3.

写入如下内容cmake_minimum_required(VERSION 2.8)project( DisplayImage )find_package( OpenCV REQUIRED )add_executable( DisplayImage DisplayImage.cpp )target_link_libraries( DisplayImage ${OpenCV_LIBS} )

使用cmd进入下载好的文件的目录,安装指令:(OpenCV是最后安装的),最好按照下面顺序安装 “pip install numpy-1.11.0+mkl-cp35-cp35m-win_amd64.whl” “pip install scipy-0.17.1-cp35-cp35m-win_amd64.whl” “pip install opencv_python-3.1.0-cp35-cp35m-win_amd64.whl”

下载的opencv2.4,在opencv文件夹中,build->python->2.7里只有cv2.pyd文件,并且复制于C:\Python27\Lib\site-packages 中是不可用的 新版的opencv(2.3/2.4)都是有python模块的,可以兼容python 2.7

安装: 命令行 pip install D:\python3.6.1\Scriptsopencv_python-3.2.0-cp36-cp36m-win_amd64.whl 测试代码: import cv2 img = cv2.imread('text.jpg',0) cv2.imshow('image',img) cv2.waitKey(0) cv2.destroyAllWindows() 结果

另外现在的许多插件都不支持Firefox,浏览其详情>>2 AutoCAD+2007+? 回答 2 3 那个版本的 opencv跟踪算法 回答 2 5 opencv如何实现多人跟踪 回答 2 1 问: opencv干什么的额 答: 详情>> 2

网站首页 | 网站地图
All rights reserved Powered by www.mdsk.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com